Deer Hunting Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I bought a new t/c triumph and the first time I pulled the trigger it did not fire off the primer
Used a remington premier sts premium.
Several primers later, there was at this point, a shot.
This is my first post, and I am new to the club.
 

·
Registered
Joined
·
8,459 Posts
Welcome TomW, This is a TC product isn't it? You could try different 209 primers, but I think I would give TC a call and let them know of your problem. TC has always been a great service company to deal with. Sounds like you're not getting enough striker contact pressure or striker alignment issue. Quick test would be to change primer manufacture and see if this solves the problem. Anyone else have some advice for Tom here? Good luck on solving the problem.
 

·
Premium Member
Joined
·
5,650 Posts
My muzzleloader box is not handy but i am thinking I used the remington kleanbore 209's. I started with a box of winchester primers and they would not allow me to close the gun to even attempt a shot. I have prob shot the t/c triumph around 50 times so far and as of yet have not had a missfire. I am going to see if I can find that thread to make sure I am right on what primers I was using.

Like huntingman said though if you have a problem T/C should take care of it.

Welcome to the club. I hope you enjoy.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for the info. Today I tried some Winchester primers that would actually fire every time. There is a real noticable difference on the length of the primer. I am going to
call t/c on monday, anyway.
 

·
Registered
Joined
·
3,608 Posts
make lots of posts
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
I called T/C and they said to check the collar behind the hammer to make sure it is in all the way and tight. They also said they use CCI primers.
Thanks for the info, i'm going to the backyard to shoot.
 

·
Registered
Joined
·
16 Posts
Triumph and 209 Primers

I had similar problems with the 209 Primers in my Triumph. It does not close at all with the Win777 primers or the regular Win Primers, but is OK with the Remington Kleanbore.

A friend of mine just bought the Triumph, similar problem. But with his the Win777 209 primers did close, but very was very tight, the Federal and Regular Winchester 209 primers did not close at all. He settled on using the CCI primers and the TC primers which are ok.

I believe the tolerances in the action are manufactured so tight that any slight deviation in the primer and it just does not close.

I personally like the Rem Kleanbore.
 

·
Registered
Joined
·
1 Posts
Same problem

I just purchased my Triumph, got to the range with my newly bought ammo-250grain shockwave and triple seven pellets and the win777 primers. put the primer in and it wouldn't close. :confused: I am going to the store today to pick up different primers and see if that fixes the problem...

I had similar problems with the 209 Primers in my Triumph. It does not close at all with the Win777 primers or the regular Win Primers, but is OK with the Remington Kleanbore.

A friend of mine just bought the Triumph, similar problem. But with his the Win777 209 primers did close, but very was very tight, the Federal and Regular Winchester 209 primers did not close at all. He settled on using the CCI primers and the TC primers which are ok.

I believe the tolerances in the action are manufactured so tight that any slight deviation in the primer and it just does not close.

I personally like the Rem Kleanbore.
 
1 - 12 of 12 Posts
Top