Deer Hunting Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Alright this is a question for all you mechanics out there. I have a 10hp Tecumseh snow king snowblower that has been on the fritz lately. Blower starts up fine and wil run perfect for about 10 min and then will all of a sudden bog down and stop running. The only thing that keeps it running is when it starts to bog I undo the gas cap and it goes back to full power. It almost seems as if it all of a sudden chokes out. So far I've checked the air filter, changed the oil, fuel cleaner/stabilizer additives, took the carb apart and cleaned it, throttle cable adjustment, choke cable adjustment, checked the belts, drained the fuel and used fresh, spark plug replaced and plug wire checked and checked the ground wire. The blower only has about 15 hrs on it. There is a 5yr warranty on it but I don't want to go thru the hassle of carting it around and having it in the shop this time of year. I'm very experienced with small engine repair & maintence, I'm able to trouble shoot and completely teardown & rebuild my atv's & snowmobile's but for some reason I just can't figure this one out. So if any gear heads out there has any suggestions please let me know!!
 

·
Premium Member
Joined
·
3,942 Posts
Man you mentioned everything that I would've thought of, maybe your cap has a funky breather setup or something. I'm stumped!
 

·
Registered
Joined
·
182 Posts
what kind of carb is on it? any numbers u could give? I had a blower that it would do the same thing but then after sitting there would be a little puddle of gas bc the bowl with the little float ring in it was getting stuck open. but i dont know if urs is like that. im not sue if that big of motor has that style of carb on it... thats all i can think of. It has to be something with the carb if it starts.
 

·
Registered
Joined
·
37 Posts
I would try a new gas cap. I had the same problem with a honda. put a new gas cap on it and it ran great forever. Your gas cap is not venting.

Good luck
 

·
Administrator
Joined
·
5,709 Posts
It also Sounds to me like you have a Cap that isn't venting properly.

You stated,
"The only thing that keeps it running is when it starts to bog I undo the gas cap and it goes back to full power"

I'd change the gas cap, that's probably your best bet at this stage ..
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #7 ·
Thanks for the tips guys. When I had the carb apart to clean it gas flows freely from the bowl out and the float doesn't appear to be hung up at all. I thought it could be the cap, the first time it happened I took the cap foam filter out and it helped some. I think for what a cap will cost I'll run to lowes in the morning and pickup a new cap. Of course this weekend it's supposed to hit low 50's and all the snow is going to melt, gotts love Michigan weather.
 

·
Registered
Joined
·
182 Posts
Thanks for the tips guys. When I had the carb apart to clean it gas flows freely from the bowl out and the float doesn't appear to be hung up at all. I thought it could be the cap, the first time it happened I took the cap foam filter out and it helped some. I think for what a cap will cost I'll run to lowes in the morning and pickup a new cap. Of course this weekend it's supposed to hit low 50's and all the snow is going to melt, gotts love Michigan weather.
im with ya on that one...
 
1 - 8 of 8 Posts
Top