Deer Hunting Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8,462 Posts
Discussion Starter · #1 ·
Well after getting the Sav 99 250-300 the casings don't want to eject. The side spring plate catches the casing about 1/2" out of the chamber and locks up. I took it to a local dealer/gunsmith and after discussion today he is baffled and cannot see whats wrong. These are no longer made and so I will have to try on line and hopefully resolve the problem whatever it is. The gunsmith is an older guy that knows his stuff but he's scratching his head right now. He removed the parts and says all look ok so right now back to square one. I can press the loading gate to the left by hand and the casing will eject ok but somethings not right. I will try to locate a new spring/plate and see if that's the problem??? Any help from a old 99 guy or new one would be of great appreciation!
 

·
Registered
Joined
·
852 Posts
Your sticky Model 99

I doubt that this is not going to help. Have you tried spraying a large amount of gun scrubber into the action and working it without a round or dummy load in the chamber. If it is nice and free then chamber a dummy
load and verify that the chamber doesn't have any burrs or corrosion.

Karl
 

·
Registered
Joined
·
8,462 Posts
Discussion Starter · #3 ·
I pick the gun up tomorrow and will take a good look at it. The part that is stopping the casing ejecting is called the auto-cutoff. It's located on the left side of the receiver and has a V type spring behind it. Compared to my 300 sav this one extends a bit farther in and so stops the casing after about 1/2-3/4" of reward travel from the chamber. I located a new spring for it and will start there and work it out I hope. Seems a simple issue but the gun smith is baffled. The gun smith was going to make sure the magazine spring tension is timed correct. Possible that someone has installed a wrong part but even the smith said all looks original. Don't know????
 

·
Registered
Joined
·
824 Posts
Another Savage 99 Lover

Well after getting the Sav 99 250-300 the casings don't want to eject. The side spring plate catches the casing about 1/2" out of the chamber and locks up. I took it to a local dealer/gunsmith and after discussion today he is baffled and cannot see whats wrong. These are no longer made and so I will have to try on line and hopefully resolve the problem whatever it is. The gunsmith is an older guy that knows his stuff but he's scratching his head right now. He removed the parts and says all look ok so right now back to square one. I can press the loading gate to the left by hand and the casing will eject ok but somethings not right. I will try to locate a new spring/plate and see if that's the problem??? Any help from a old 99 guy or new one would be of great appreciation!
Talked to my father-in-law about your issue. He has a similar model, but in .300 Savage. He says you have either a worn extractor spring or that there is too much dirt/grime underneath to allow it to grab the lip of the cartridge. It's his best guess with me telling him about it over the phone without actually seeing it.

Can you disassemble everything then use a really fine stone on all of the bolt's edges that would/could wear or cause burrs on the metal? He emphasized a really, really fine stone so as not to cause too much wear. If you have any question send a PM and I can forward you on to father-in-law.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top