Just ordered t/c triumph - Page 3 - Deer Hunting Forums
MuzzleLoader Hunting Discuss MuzzleLoader topics

Reply
 
Thread Tools Display Modes
post #21 of 22 (permalink) Old 11-02-2007, 09:26 PM Thread Starter
Moderator
 
buckfever's Avatar
 
Join Date: Nov 2006
Location: Tennessee
Posts: 5,650
it shot fairly well. ive got my scope mounted. ive taken and shot with it 3 times so far. im using the t/c shockwaves. they are tough to load. but i beleive its that way with mose t/c guns. i am using the remington kleanbore primers. i was mistaken in a previous post and accidently bought the winchester 777s. like the author in the post stated the winchester 777s would not allow the gun to close. i will be hunting with it in the morning for the first time. wish me luck
buckfever is offline  
Advertisement
 
post #22 of 22 (permalink) Old 11-03-2007, 06:55 AM
 
BruceBruce1959's Avatar
 
Join Date: Jan 2007
Location: Vermont
Posts: 5,701
Good Luck !!!!!

Democracy is two wolves and a lamb voting on what to have for lunch.
Liberty is a well-armed lamb contesting the outcome of the vote.
-Benjamin Franklin

BruceBruce1959 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Deer Hunting Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome