Breech plug issues - Deer Hunting Forums

Go Back   Deer Hunting Forums > General Forums > MuzzleLoader Hunting
MuzzleLoader Hunting Discuss MuzzleLoader topics

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1 (permalink)  
Old 10-18-2012, 07:50 AM
findmeoutside findmeoutside is offline
B&C 100 Class
 
Join Date: Oct 2012
Posts: 33
Default Breech plug issues

hey guys have a question went to clean my muzzleloader last night its a CVA Wolf nothing special but shoots well when working... pulled the breech plug and firing pin to clean both i know firing pin is not a common spot to clean but i have had issues with this sticking... i now cannot get the breech plug to thread back in i believe i may have boogered the threads a little... any idea on whether i can actually get a tap and tap this or does it have to go to a gunsmith??
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Top Posters
Hunting Man8082
buckfever5650
BruceBruce19595588
timberghost3937
joel the signman3608
tator3204
gfdeputy23113
delbert1524
Buckshot1219
hunt NH1203
Photos
Bow String Depot Strings
Bow String Depot
Bow String Depot Strings


All times are GMT -5. The time now is 02:24 PM.


User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

LinkBacks Enabled by vBSEO 3.0.0 RC8