Snowblower Question - Deer Hunting Forums

Go Back   Deer Hunting Forums > General Forums > The Campfire
The Campfire Got something besides hunting on your mind? Discuss anything "off topic" around the campfire.

Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old 01-03-2008, 07:42 PM
BukSeker BukSeker is offline
B&C 100 Class
 
Join Date: Dec 2007
Location: Holland, michigan
Posts: 35
Default Snowblower Question

Alright this is a question for all you mechanics out there. I have a 10hp Tecumseh snow king snowblower that has been on the fritz lately. Blower starts up fine and wil run perfect for about 10 min and then will all of a sudden bog down and stop running. The only thing that keeps it running is when it starts to bog I undo the gas cap and it goes back to full power. It almost seems as if it all of a sudden chokes out. So far I've checked the air filter, changed the oil, fuel cleaner/stabilizer additives, took the carb apart and cleaned it, throttle cable adjustment, choke cable adjustment, checked the belts, drained the fuel and used fresh, spark plug replaced and plug wire checked and checked the ground wire. The blower only has about 15 hrs on it. There is a 5yr warranty on it but I don't want to go thru the hassle of carting it around and having it in the shop this time of year. I'm very experienced with small engine repair & maintence, I'm able to trouble shoot and completely teardown & rebuild my atv's & snowmobile's but for some reason I just can't figure this one out. So if any gear heads out there has any suggestions please let me know!!
__________________
BuKseKer
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-03-2008, 08:44 PM
timberghost's Avatar
timberghost timberghost is offline
Moderator
 
Join Date: Oct 2007
Location: western new york
Posts: 3,930
Default

Man you mentioned everything that I would've thought of, maybe your cap has a funky breather setup or something. I'm stumped!
Reply With Quote
  #3 (permalink)  
Old 01-04-2008, 12:46 AM
burgerking's Avatar
burgerking burgerking is offline
B&C 100 Class
 
Join Date: Oct 2007
Location: Southern Michigan
Posts: 182
Default

what kind of carb is on it? any numbers u could give? I had a blower that it would do the same thing but then after sitting there would be a little puddle of gas bc the bowl with the little float ring in it was getting stuck open. but i dont know if urs is like that. im not sue if that big of motor has that style of carb on it... thats all i can think of. It has to be something with the carb if it starts.
__________________
Cholesterol kills more people than guns do, makes laws to control that!
Reply With Quote
  #4 (permalink)  
Old 01-04-2008, 04:03 AM
skidtrail skidtrail is offline
B&C 100 Class
 
Join Date: Dec 2006
Location: WA State
Posts: 37
Default

I would try a new gas cap. I had the same problem with a honda. put a new gas cap on it and it ran great forever. Your gas cap is not venting.

Good luck
Reply With Quote
  #5 (permalink)  
Old 01-04-2008, 06:54 AM
BruceBruce1959's Avatar
BruceBruce1959 BruceBruce1959 is offline
 
Join Date: Jan 2007
Location: Vermont
Posts: 5,488
Default

It also Sounds to me like you have a Cap that isn't venting properly.

You stated,
"The only thing that keeps it running is when it starts to bog I undo the gas cap and it goes back to full power"

I'd change the gas cap, that's probably your best bet at this stage ..
__________________
Democracy is two wolves and a lamb voting on what to have for lunch.
Liberty is a well-armed lamb contesting the outcome of the vote.
-Benjamin Franklin

Reply With Quote
  #6 (permalink)  
Old 01-04-2008, 08:28 AM
timberghost's Avatar
timberghost timberghost is offline
Moderator
 
Join Date: Oct 2007
Location: western new york
Posts: 3,930
Default

Skidtrail and Bruce hit it on the head, that's what I meant, couldn't phrase it properly.
Reply With Quote
  #7 (permalink)  
Old 01-04-2008, 06:15 PM
BukSeker BukSeker is offline
B&C 100 Class
 
Join Date: Dec 2007
Location: Holland, michigan
Posts: 35
Default

Thanks for the tips guys. When I had the carb apart to clean it gas flows freely from the bowl out and the float doesn't appear to be hung up at all. I thought it could be the cap, the first time it happened I took the cap foam filter out and it helped some. I think for what a cap will cost I'll run to lowes in the morning and pickup a new cap. Of course this weekend it's supposed to hit low 50's and all the snow is going to melt, gotts love Michigan weather.
__________________
BuKseKer
Reply With Quote
  #8 (permalink)  
Old 01-05-2008, 12:34 AM
burgerking's Avatar
burgerking burgerking is offline
B&C 100 Class
 
Join Date: Oct 2007
Location: Southern Michigan
Posts: 182
Default

Quote:
Originally Posted by BukSeker View Post
Thanks for the tips guys. When I had the carb apart to clean it gas flows freely from the bowl out and the float doesn't appear to be hung up at all. I thought it could be the cap, the first time it happened I took the cap foam filter out and it helped some. I think for what a cap will cost I'll run to lowes in the morning and pickup a new cap. Of course this weekend it's supposed to hit low 50's and all the snow is going to melt, gotts love Michigan weather.
im with ya on that one...
__________________
Cholesterol kills more people than guns do, makes laws to control that!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Top Posters
Hunting Man7816
buckfever5650
BruceBruce19595488
timberghost3930
joel the signman3608
tator3193
gfdeputy22974
delbert1519
Buckshot1219
hunt NH1203
Photos
My SASKATCHEWAN BUCKS
James Weist
My SASKATCHEWAN BUCKS
Team DHC Articles


    All times are GMT -5. The time now is 07:33 AM.



    LinkBacks Enabled by vBSEO 3.0.0 RC8